[r6rs-discuss] [Formal] "Byte-vector" would be a better name than
"bytes" for a data type.
Arthur A. Gleckler
arthur at zurich.csail.mit.edu
Tue Nov 14 00:09:59 EST 2006
This message is a formal comment which was submitted to formal-comment at r6rs.org, following the requirements described at: http://www.r6rs.org/process.html
Name: Arthur A. Gleckler
Email: r6rs at speechcode.com
In <11. Bytes objects>, I suggest using the term "byte-vector"
instead of "bytes." A plural name for the type will lead to
confusion and is inconsistent with the names used for all other
Scheme types. Even if "byte-vector" isn't chosen, please consider a
singular name. I'd much rather say "two byte-vectors" instead of
"two byteses" or "two objects of type bytes" or the ambiguous "two
More information about the r6rs-discuss