[r6rs-discuss] [Formal] "Byte-vector" would be a better name than
"bytes" for a data type.
David T. Pierson
dtp at mindstory.com
Wed Nov 15 23:42:27 EST 2006
On Mon, Nov 13, 2006 at 09:09:59PM -0800, Arthur A. Gleckler wrote:
> In <11. Bytes objects>, I suggest using the term "byte-vector"
> instead of "bytes." A plural name for the type will lead to
> confusion and is inconsistent with the names used for all other
> Scheme types. Even if "byte-vector" isn't chosen, please consider a
> singular name. I'd much rather say "two byte-vectors" instead of
> "two byteses" or "two objects of type bytes" or the ambiguous "two
While I agree that having a plural name for a type is not ideal, I do
not like the name "byte-vector" if this type is to be disjoint from the
vector type. A byte-vector that is not a vector would be at least as
confusing as a bytes that is a single object.
I also think that a one-word name for a type is highly preferable when
it is to be used as the prefix for (many) procedures related to this type.
I also note that PLT Scheme introduced a bytes type about a year ago
IIRC. I don't recall anyone on the PLT mailing list having trouble with
it, but perhaps someone else does?
So I would prefer "bytes" to "byte-vector", but here are some other
binary (Jeff Read's suggestion from Erlang)
byfer (portmanteau for byte buffer)
bytor (portmanteau for byte vector)
My vote would be for any of the one word names.
More information about the r6rs-discuss