[r6rs-discuss] [Formal] Simplifying conditions
andre at het.brown.edu
Sun Nov 26 17:03:30 EST 2006
A couple of minor comments on the suggested changes:
On Sun, 26 Nov 2006, Michael Sperber wrote:
> (explode-condition condition)
I would suggest condition->list instead. It seems more consistent with naming
conventions elsewhere. Also, I assume that if condition is simple, this will
return a singleton list, right?
> The following replaces the current specification of the `condition'
> The condition returned by condition is created by a call of form
> (make-condition <condition-type> '<field-name> <exp>...)
Here make-condition must take an alist to be consistent with the above.
More information about the r6rs-discuss