[r6rs-discuss] [Formal] Rename bitwise-arithmetic-shift to bitwise-shift etc.
bjh21 at bjh21.me.uk
Mon Apr 23 18:40:32 EDT 2007
On Fri, 20 Apr 2007, Felix Klock wrote:
> I see how your first paragraph provides evidence for your conclusion
> with respect to page 42, but page 38 is part of the specification for
> the (r6rs arithmetic fx) library, where the numbers are specified to
> have definite length, and therefore a hypothetical fxlogical-shift
> operation is not meaningless.
> Do you have a separate justification for your suggested changes to
> page 38?
No. The renaming of fxarithmetic-shift is for consistency with
bitwise-arithmetic-shift on the assumption that names in (r6rs arithmetic
fx) should track names elsewhere in the standard. I think this is a
better approach than either allowing the two names to diverge or keeping
the current unwieldy names.
In particular, I think that fxlogical-shift would be a conceptually
substantially uglier operation than fxarithmetic-shift, and that it's thus
perfectly OK for it to have an uglier name.
More information about the r6rs-discuss